BitScope Chart | Notes


BitScope DSO, Logic, Chart, Meter and Library updated

Changes in the Linux kernel that have appeared in recent editions of Ubuntu and Fedora caused problems for these applications when used with some model USB BitScopes. These included BS300, BS310, BS50 and some BS1xx models. This update addresses these issues. If you use Ubuntu or Fedora and run into trouble with one of these models please upgrade to the latest production release. Windows, Mac and Raspberry Pi are unaffected.


Chart 1.1.DK05A Mac OS X Maverics, Sydney & Linux 3.8+

BitScope Chart on Mac OS X 10.9 Mavericks

BitScope Chart on Mac OS X 10.9 Mavericks

Apple released Mavericks recently so we've been working to ensure our software remains compatible. This update makes some changes required to avoid a bugs we found when older versions were run in Mavericks. It also fixes a bug reported when some USB BitScope models are used with Fedora 19 or Ubuntu 13.10 Linux. These include BS300, BS301, BS310, BS50 and BS320. Some early editions of BS100 and BS120 may also be affected. If you have difficulties connecting with a Linux system which uses the kernel revision 3.8 or later and you have reviewed our USB troubleshooting guide to ensure it's not a different issue, we recommend you upgrade to this release.


Chart 1.1 | Mac OS X Mountain Lion Release | DC01G

BitScope Chart now works with the latest Mac OS X as part of our Mountain Lion Update.

Mac OS X Mountain Lion

Ths is the first release for Mac OS X.

It is compatible with all current model BitScopes and older models back to 2003. All the features of the Windows and Linux versions are available on Mac OS X including the ability to chart frequency and period on up to 16 channels or voltage statistics on up to 8 channels.

To install simply download the update and drag the app to your Applications folder. As with the other app updates Chart is also faster due the use of the a new link driver so we've updated for Windows and Linux too. The driver is activated by default for Linux and Mac OS X and can be manually enabled via the FTDI device properties for the USB device created by Windows when a USB BitScope is first connected by reducing the USB latency timer setting to 2ms.


Chart 1.1 | Windows and Linux 64 bit Release | CI14A

This release introduces 64-bit versions for Windows 7 and most 64-bit Linux distributions.

64-bit Linux/Windows Release (beta)

This update has been made possible with the release of the new BitScope Library also available as a 64-bit native release.

If you are running Windows 7/64 or 64 bit versions of Ubuntu, Debian, Mint, Fedora, RedHat or other 64 bit Linux distributions we recommend you upgrade to the 64 bit version of DSO. We've also fixed bugs caused by Ubuntu's adoption of overlay scrollbars as part of their "touch ready" Unity Interface. Logic now runs without the need for the tweaks reported for DSO at BK04D


Chart 1.1 | HAL Compatibilty Update | CC02A

This update adds the hardware abstraction layer (HAL) used by DSO 2.5 to BitScope Chart.

HAL Compatibility Update

It effectively replaces the driver layer in Logic to ensure compatibility with new firmware revisions of BS10 as well as older model BitScopes such as BS50U which previously did not work with Chart.

More updates coming soon as we fix known bugs in this release:

  • Application start-up can be very slow in this release. It should connect but may take up to 20 seconds to do so.
  • Frequency lock sometimes drops intermittently when running multiple concurrent frequency channels.
  • Chart reports that BS10 has BNC inputs (which clearly it doesn't). Simply choose the POD inputs.

Please email with bug reports or questions.


Chart 1.1 | Online Update | CB28B

This is a downloadable update of BitScope Chart for existing BitScope owners. It fixes several reported bugs. A BitScope Chart update will be made available soon for use with BS10.


Chart 1.1 | Initial Beta Release | BE03A

This is the first 1.1 beta release ahead of the next production version (1.2). It fixes a range of minor bugs. It introduces some new features which may have some bugs. This version also has built-in expiry (2011-07-31) so we don't recommend it for production environments. If this concerns you we recommend you continue using the 1.0 production release which is stable and never expires.